View Issue Details

IDProjectCategoryView StatusLast Update
0009252Legion CoreGeneralpublic2020-03-26 17:06
ReporterSulphosAssigned Tomakcimys93 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Summary0009252: Killpoints reset after mission follower legendary drop?
DescriptionI've been hearing of the suspicion from fellow players that killpoints might not only get reset if a legendary equipment item drops but if ANY Legion legendary item drops, such as mission follower legendary items. Possibly even if you buy a legendary with essences.

So far only one legendary equipment item has dropped for me which is a pretty low rate compared to the official servers at this patch, but of course this is not a proof, and a player obviously cannot have a proof for a bug like this. I received a couple of legendary follower items. A minute ago, the follower legendary item "Omen's Bidding" dropped for me. Afterwards I immediately logged out. I kindly ask to check my killpoints. If they are 0 then the bug is proven. If they are not then I'm grateful for checking and this report can be closed. I apologize for creating this ticket without having an actual proof (which I can't have in this case). I appreciate the help.

Activities

Sulphos

2020-03-20 02:55

reporter   ~0026183

Edit: Character is: Sulphos on ArgusWoW x100 (Affliction Warlock)

makcimys93

2020-03-20 22:40

updater   ~0026251

I will collect complete information, and then send to the developer.

Sulphos

2020-03-23 20:15

reporter   ~0026440

Looks like a false alert.. received one today.. please feel free to close ticket :)

Issue History

Date Modified Username Field Change
2020-03-19 23:32 Sulphos New Issue
2020-03-20 02:55 Sulphos Note Added: 0026183
2020-03-20 11:14 Alica228 Assigned To => makcimys93
2020-03-20 11:14 Alica228 Status new => assigned
2020-03-20 22:40 makcimys93 Note Added: 0026251
2020-03-20 22:40 makcimys93 Status assigned => confirmed
2020-03-23 20:15 Sulphos Note Added: 0026440
2020-03-24 13:05 makcimys93 Status confirmed => resolved
2020-03-24 13:05 makcimys93 Resolution open => fixed