View Issue Details

IDProjectCategoryView StatusLast Update
0015710Legion CoreClasses - Warlock - Чернокнижникpublic2021-09-11 04:49
ReporterzeakeyAssigned ToGhost 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOS10OS Versionx64
Summary0015710: https://www.wowhead.com/item=128942/ulthalesh-the-deadwind-harvester?bonus=0 modifies DoTs in wrong way
DescriptionSo I noticed that every time I would shake off combat and go for a drink in arena/bg my drinking would still get interrupted. I tried my own warlock to see what is up. So I tried without artefact and everything was fine. But when I equipped Affliction warlock artefact ALL dots( Corruption, Agony, Syphon, Unstable affliction, etc.) Would break my drinking even though I am still out of combat.



There are instances when drinking can be broken via dots with spells like https://www.wowhead.com/spell=191685/virulent-eruption. However this is a known case and the only exception. Also it puts enemy in to combat. Which is the reason why drinking stops in a first place.

These DoTs are affected by some unknown forces from Affliction Artefact that makes them literally never let any healer in arena or BG to ever drink any mana.

If I was able to level up my https://www.wowhead.com/item=128942/ulthalesh-the-deadwind-harvester?bonus=0 from scratch I would be able to isolate which specific passive from Artefact causes the issue.

Please investigate.

Additional InformationОт тестера:
Это работает только с афли спеком при надетом https://www.wowhead.com/item=128942/ulthalesh-the-deadwind-harvester?bonus=0
Как повторить, при надетом (https://www.wowhead.com/item=128942/ulthalesh-the-deadwind-harvester?bonus=0) кидаешь любую из этих дот: https://ru.wowhead.com/spell=980/%D0%B0%D0%B3%D0%BE%D0%BD%D0%B8%D1%8F, https://ru.wowhead.com/spell=172/%D0%BF%D0%BE%D1%80%D1%87%D0%B0, https://ru.wowhead.com/spell=63106/%D0%B2%D1%8B%D1%82%D1%8F%D0%B3%D0%B8%D0%B2%D0%B0%D0%BD%D0%B8%D0%B5-%D0%B6%D0%B8%D0%B7%D0%BD%D0%B8 и садишься пить, и питье тут же спадает при тике дот.
Если это делать без (https://www.wowhead.com/item=128942/ulthalesh-the-deadwind-harvester?bonus=0) то не сбрасывается питье

Activities

Mdnss

2021-07-24 12:53

reporter   ~0046961

Любой урон прерывает питье и так всегда было. При чем тут варлоки и их арт?

zeakey

2021-07-24 15:34

reporter   ~0046965

Nope. None of the other classes do that with their DoTs. Affliction is clearly broken.

Here is an example of retail where dot doesn't break drinking.
24:47 - Cdew sits down. Starts drink. Gets hit by Boomkin dot. Drink aura persists. Then he stands up. And only then it breaks.
https://www.youtube.com/watch?v=qPjZU4nx4qE&t=1487s

Unless you want to send me video where it does break drinking on DoT damage?

zeakey

2021-07-24 16:55

reporter   ~0046968

Only direct application should stop drinking/capping flag. But periodic damage should not.

Mdnss

2021-07-24 18:01

reporter   ~0046970

Урон от доты на видео проходит во время анимации "ситдауна". Если бы игрок продолжил пить, то персонаж бы встал автоматически в конце анимации(или после следующего тика - тут я не уверен). Именно поэтому пить под дотами ВОЗМОЖНО (на нашем сервере тоже), но эффективность этого ниже и уходит больше "бутылок".
https://us.forums.blizzard.com/en/wow/t/eating-with-dots/354237

zeakey

2021-07-24 18:25

reporter   ~0046971

Thank you for that proof. Literally 2 (especially from Warlock) comments there saying that I am right about dots not breaking drinks. And the last third from paladin (non dot class) doubtfully saying that it MIGHT.

And you really think a 3k + retail gladiator would go for a drink with dots on him before using a bubble on himself as a priest? Think logically please.

Also if you think you are right go and make dozen reports for every other spec besides affliction warlock that have dots and do not break drinking upon dot damage.

Also your method of resitting not working against affliction warlock. There is a 4 sec delay before drink mana regen kicks in.

zeakey

2021-07-24 18:37

reporter   ~0046972

Another record of mentioning being able to eat with DoTs

https://www.reddit.com/r/worldofpvp/comments/58xnoy/what_circumstances_can_you_eat_in_arena_during/

Mdnss

2021-07-24 19:01

reporter   ~0046973

Я только информирую, как это работает)
Пруфы нужны от тебя, а их нет.
Вот тема на вовхеде (такого же умника, который нашел "баг".)
https://www.wowhead.com/forums/topic/drinking-in-arena-battlegrounds-bug-226627
И ответ ему:
"It could be caused by DoT effects on you.
You can get out of combat while they're still ticking on you, and start drinking/eating, but whenever you take damage from a tick, you'll stop drinking/eating, but not get into combat, so just keep spamming your drink/food until said DoT(s) wear off, you should still get some regen in."

zeakey

2021-07-24 19:56

reporter   ~0046976

If you ever played MoP. You would know such spell as https://www.wowhead.com/spell=112833/spectral-guise. Which was deliberately nerfed due to it's ability to instantly drop combat and drink. So instead after you drop combat, you weren't able to drink for 4 sec.

Which is why he said:
"Hey Panik8 :)
I did some arena battles yesterday and i paid attention on my dots/debuffs when leaving out of combat to drink. The problem occurs even when i'm "fully clean", probably its some 'great' blizzard idea, like the never ending cc :)"

zeakey

2021-07-24 20:00

reporter   ~0046977

6:10 - eating while under DK DoT. He did have a bubble though. However, with our Affliction warlock bug. Even bubble wont protect you from drinking.
https://www.youtube.com/watch?v=SpQUtmPMDP4

Mdnss

2021-07-24 20:00

reporter   ~0046978

)))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))

zeakey

2021-07-24 20:08

reporter   ~0046979

9:24 - drinking without bubble with DoTs. But since Dk has https://www.wowhead.com/spell=191587/virulent-plague it has a chance to erupt and cause aoe explosion that puts you in combat. The drinking didn't last long.
https://www.youtube.com/watch?v=SpQUtmPMDP4

Mdnss

2021-07-24 20:15

reporter   ~0046980

на 6:10 маг продолжает пить, потому что урон уходит в абсорб.
на 9:24 он бы перестал пить в любом случае (под любой дотой) (даже не входя в режим боя), потому что урон прошел и персонаж изза этого встает с места.

Mdnss

2021-07-24 20:18

reporter   ~0046981

Скинь видео, где персонаж:
1. Получает урон от доты (сидя)
2. Не входит в режим боя
3. Продолжает пить после этого
Это будет реальный пруф.

zeakey

2021-07-24 20:24

reporter   ~0046982

I already provided proof where he is drinking with dot dmg ticking on him without bubble. That is all what is needed for this report. Please stop flooding this thread if you don't have anything useful to say. Thank you.

9:24 - 9:29 Drinking doesn't break when stetting and getting damaged and out of combat.

https://www.youtube.com/watch?v=SpQUtmPMDP4

Mdnss

2021-07-24 20:51

reporter   ~0046983

На 9:24 такая же ситуация, как в видео с пристом (урон проходит в момент анимации "ситдауна") (персонаж еще не сидит)
https://wowwiki-archive.fandom.com/wiki/Sit
"The first damage taken while sitting will cause a target to immediately stand."

zeakey

2021-07-24 21:42

reporter   ~0046984

Let me quote whole message from https://wowwiki-archive.fandom.com/wiki/Sit

"MELEE attacks against a sitting target automatically hit and cause double damage. The first damage taken while sitting will cause a target to immediately stand."

I understand that you play warlock and you don't want anything fixed. Please be fair to other classes and stop posting nonsense.

Mdnss

2021-07-24 22:25

reporter   ~0046987

))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))

Kyckax

2021-07-25 14:36

updater   ~0046992

Hello, I confirm, I transfer to the developer

Ghost

2021-07-25 14:44

developer   ~0046993

о чем здесь вообще речь?

zeakey

2021-07-25 17:58

reporter   ~0046997

Ghost privet.

When you have https://www.wowhead.com/item=128942/ulthalesh-the-deadwind-harvester?bonus=0 equipped all warlock damage overtime gains power to keep you on your feet no matter if you are in combat or not. So you cant sit down and drink at all if you have any of the warlock dot on you.

The only time damage overtime should break drinking is when it is applied directly on the target. This isn't broken on any other specs but Affliction warlock with this weapon.

zeakey

2021-07-26 16:34

reporter   ~0047013

Ja sam mogu proverit kakoij imenno "spell ID" dajot etot bug. Tolko mne nuzen account s dostupom k ".aura <spell name> " commande.

zeakey

2021-07-26 16:36

reporter   ~0047014

i eta komanda toze nuzna ".learn <spell name> "

Issue History

Date Modified Username Field Change
2021-07-24 01:32 zeakey New Issue
2021-07-24 01:32 zeakey Status new => assigned
2021-07-24 01:32 zeakey Assigned To => Shadowraze
2021-07-24 12:53 Mdnss Note Added: 0046961
2021-07-24 12:56 Kyckax Assigned To Shadowraze => Kyckax
2021-07-24 15:34 zeakey Note Added: 0046965
2021-07-24 16:55 zeakey Note Added: 0046968
2021-07-24 18:01 Mdnss Note Added: 0046970
2021-07-24 18:25 zeakey Note Added: 0046971
2021-07-24 18:37 zeakey Note Added: 0046972
2021-07-24 19:01 Mdnss Note Added: 0046973
2021-07-24 19:56 zeakey Note Added: 0046976
2021-07-24 20:00 zeakey Note Added: 0046977
2021-07-24 20:00 Mdnss Note Added: 0046978
2021-07-24 20:08 zeakey Note Added: 0046979
2021-07-24 20:15 Mdnss Note Added: 0046980
2021-07-24 20:18 Mdnss Note Added: 0046981
2021-07-24 20:24 zeakey Note Added: 0046982
2021-07-24 20:51 Mdnss Note Added: 0046983
2021-07-24 21:42 zeakey Note Added: 0046984
2021-07-24 22:25 Mdnss Note Added: 0046987
2021-07-25 14:36 Kyckax Note Added: 0046992
2021-07-25 14:36 Kyckax Assigned To Kyckax => Ghost
2021-07-25 14:36 Kyckax Status assigned => confirmed
2021-07-25 14:40 Kyckax Additional Information Updated View Revisions
2021-07-25 14:44 Ghost Note Added: 0046993
2021-07-25 17:58 zeakey Note Added: 0046997
2021-07-26 16:34 zeakey Note Added: 0047013
2021-07-26 16:36 zeakey Note Added: 0047014
2021-09-11 04:49 Ghost Status confirmed => resolved
2021-09-11 04:49 Ghost Resolution open => fixed