View Issue Details

IDProjectCategoryView StatusLast Update
0015696Legion CoreClasses - Paladin - Паладинpublic2021-07-23 17:42
ReporterzeakeyAssigned ToKyckax 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOS10OS Versionx64
Summary0015696: Beacon of Light spell list
DescriptionCurrently https://www.wowhead.com/spell=53563/beacon-of-light , https://www.wowhead.com/spell=200025/beacon-of-virtue and https://www.wowhead.com/spell=156910/beacon-of-faith transfers all of the healing. Biggest culprit at the moment is Avenging Crusader. This makes paladins extremely powerful therefore marked with URGENT.

Should only transfer these:

Flash of Light
Holy Shock
Holy Light
Light of Dawn
Light of the Martyr

Proof 7.3.5 archives:

https://web.archive.org/web/20180609005654/https://www.wowhead.com/spell=53563/beacon-of-light

Activities

zeakey

2021-07-22 04:49

reporter   ~0046891

Also
https://www.wowhead.com/spell=183998/light-of-the-martyr also shouldn't be transferred. Due to it having an actual note saying it shouldn't.

zeakey

2021-07-22 18:18

reporter   ~0046912

The one above seems to be 8.x.x +

In 7.3.5 it was the same anyways. Here is updated log from 7.3.5

Archive correction: https://web.archive.org/web/20170810164403/http://www.wowhead.com/spell=53563/beacon-of-light#changelog

Kyckax

2021-07-22 21:31

updater   ~0046918

Hello, should healing be triggered by triggered healers?
Like a https://www.wowhead.com/spell=216331/avenging-crusader

zeakey

2021-07-22 21:49

reporter   ~0046919

I gave you the list. However here is a detailed list of triggers for your favourite spell.

https://imgbb.com/

As you can see Beacon of Light isn't there.

While spells such as Light of Dawn do have it:

https://imgbb.com/

Avenging Crusader currently does insane healing with Beacon of Light spells. It is trully game breaking. However that isn't the only spell that not suppose to work with Beacon. https://www.wowhead.com/spell=223306/bestow-faith also should work with beacon. However it does on uwow.

zeakey

2021-07-22 21:51

reporter   ~0046920

Avenging Crusader - https://ibb.co/3y97h0m
Light of Dawn - https://ibb.co/C0JdPDW

Kyckax

2021-07-22 22:46

updater   ~0046925

I asked you a question not on the beacons and lists of what the beacon should transmit, but whether the heal from triggered healings (https://www.wowhead.com/spell=216331/avenging-crusader) should work

zeakey

2021-07-22 23:15

reporter   ~0046926

If you use macro /combatlog macro you will see the healing spell id for Avenging Crusader. That spell ID has no relation to Beacon of Light whatso ever. So no it should not heal because they aren't interlinked.

Kyckax

2021-07-22 23:46

updater   ~0046928

Last edited: 2021-07-22 23:52

View 4 revisions

So why do you think it should be on the beacon spell list? If the spell is not self-contained

zeakey

2021-07-23 02:01

reporter   ~0046930

It shouldn't. This whole report is about that. Please read thoroughly.

Kyckax

2021-07-23 12:00

updater   ~0046936

Last edited: 2021-07-23 12:05

View 2 revisions

Hello, i found proof, check this video
https://youtu.be/gcIpPriGQ4o?t=92 (1:32)
Hpaly use https://www.wowhead.com/spell=20271/judgment and https://www.wowhead.com/spell=216331/avenging-crusader + https://www.wowhead.com/spell=53563/beacon-of-light gave healing his teammate

zeakey

2021-07-23 17:26

reporter   ~0046944

Thank you Kyckax for your effort. I also found this that can put this report a rest. It says there that it does indeed transfer Avenging healing.

https://www.reddit.com/r/worldofpvp/comments/5hex9o/avenging_crusader_how_it_works_and_when_to_use/

Happy pala gameplay :D

Please close.

Issue History

Date Modified Username Field Change
2021-07-22 03:22 zeakey New Issue
2021-07-22 03:22 zeakey Status new => assigned
2021-07-22 03:22 zeakey Assigned To => Shadowraze
2021-07-22 04:49 zeakey Note Added: 0046891
2021-07-22 18:18 zeakey Note Added: 0046912
2021-07-22 19:37 Shadowraze Assigned To Shadowraze => Kyckax
2021-07-22 21:31 Kyckax Note Added: 0046918
2021-07-22 21:32 Kyckax Status assigned => feedback
2021-07-22 21:49 zeakey Note Added: 0046919
2021-07-22 21:49 zeakey Status feedback => assigned
2021-07-22 21:51 zeakey Note Added: 0046920
2021-07-22 22:46 Kyckax Note Added: 0046925
2021-07-22 22:48 Kyckax Status assigned => feedback
2021-07-22 23:15 zeakey Note Added: 0046926
2021-07-22 23:15 zeakey Status feedback => assigned
2021-07-22 23:46 Kyckax Note Added: 0046928
2021-07-22 23:46 Kyckax Status assigned => feedback
2021-07-22 23:50 Kyckax Note Edited: 0046928 View Revisions
2021-07-22 23:50 Kyckax Note Edited: 0046928 View Revisions
2021-07-22 23:52 Kyckax Note Edited: 0046928 View Revisions
2021-07-23 02:01 zeakey Note Added: 0046930
2021-07-23 02:01 zeakey Status feedback => assigned
2021-07-23 12:00 Kyckax Note Added: 0046936
2021-07-23 12:05 Kyckax Note Edited: 0046936 View Revisions
2021-07-23 12:05 Kyckax Status assigned => feedback
2021-07-23 17:26 zeakey Note Added: 0046944
2021-07-23 17:26 zeakey Status feedback => assigned
2021-07-23 17:42 Kyckax Status assigned => closed
2021-07-23 17:42 Kyckax Resolution open => fixed